About This Site

This site is designed to give you a top level view of any outage that may occur on the Simple Servers network. The page will update automatically with no need for a browser refresh. Further updates will also be posted on twitter @simplehostinguk

18th July 2016

Shared Hosting Shared October Server

We are currently investigating connectivity issues with shared October server

Update (08:48): We are investigating issues with this server
Update (09:09): An engineer is looking at the server
Update (09:20): There was high load, this has now been mitigated